import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\+?\\d*\\s?(?:\\(\\d+\\)\\s?\\d+([-\\s.]?)(?:\\1?\\d)*|([.\\s-]?)(?:\\2?\\d)*)$";
final String string = "+123(12) 111-2334";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}