re = /^\+?\d*\s?(?:\(\d+\)\s?\d+([-\s.]?)(?:\1?\d)*|([.\s-]?)(?:\2?\d)*)$/m
str = '+123(12) 111-2334'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end