package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+(?:[.,]\d+)?)`)
var str = `Есть стринга типа 'asda12312.234234ertert,34534'. Нужно достать из неё только цифры ипервую точку или запятую.
'asda12312.234234ertert,34534' => '12312.23423434534'
'asda12312,234234ertert,34534' => '12312,23423434534'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}