import Foundation
let pattern = #"(\d+(?:[.,]\d+)?)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Есть стринга типа 'asda12312.234234ertert,34534'. Нужно достать из неё только цифры ипервую точку или запятую.
'asda12312.234234ertert,34534' => '12312.23423434534'
'asda12312,234234ertert,34534' => '12312,23423434534'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)