#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(?=[A-Z-\/_]{0,}[0-9]{3,})[A-Z0-9-\/_]{7,}"
Local $sString = "Te poniższe bym chciał:" & @CRLF & _
"ZOC1050056" & @CRLF & _
"23639583" & @CRLF & _
"GL20/11878/17" & @CRLF & _
"20700246365_1" & @CRLF & _
"WR50/11349/17" & @CRLF & _
"PL201709120448" & @CRLF & _
"pl2017072600414" & @CRLF & _
"1054332/1133787" & @CRLF & _
"H201709201932-01" & @CRLF & _
"143392/DLS/17 " & @CRLF & _
"KO/455/17" & @CRLF & _
"12222222/22" & @CRLF & _
"" & @CRLF & _
"a to już false positives: " & @CRLF & _
"66565" & @CRLF & _
"bardzodlugieslowo" & @CRLF & _
"niechcetegoo?" & @CRLF & _
"2/zamalocyfer" & @CRLF & _
"32tubysietez przydalo wiecej"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")