import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=[A-Z-\\/_]{0,}[0-9]{3,})[A-Z0-9-\\/_]{7,}";
final String string = "Te poniższe bym chciał:\n"
+ "ZOC1050056\n"
+ "23639583\n"
+ "GL20/11878/17\n"
+ "20700246365_1\n"
+ "WR50/11349/17\n"
+ "PL201709120448\n"
+ "pl2017072600414\n"
+ "1054332/1133787\n"
+ "H201709201932-01\n"
+ "143392/DLS/17 \n"
+ "KO/455/17\n"
+ "12222222/22\n\n"
+ "a to już false positives: \n"
+ "66565\n"
+ "bardzodlugieslowo\n"
+ "niechcetegoo?\n"
+ "2/zamalocyfer\n"
+ "32tubysietez przydalo wiecej";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}