use strict;
my $str = 'Te poniższe bym chciał:
ZOC1050056
23639583
GL20/11878/17
20700246365_1
WR50/11349/17
PL201709120448
pl2017072600414
1054332/1133787
H201709201932-01
143392/DLS/17
KO/455/17
12222222/22
a to już false positives:
66565
bardzodlugieslowo
niechcetegoo?
2/zamalocyfer
32tubysietez przydalo wiecej';
my $regex = qr~(?=[A-Z-\/_]{0,}[0-9]{3,})[A-Z0-9-\/_]{7,}~imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}