package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(\w+)$`)
var str = `ANGULAR CONTACT (ROLLING) BEARING
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}