using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\d\.\s]+";
string input = @"3.1. Задание 1.jpg
3.2 Задание 1. Расчет ИМТ.docx
4. Задание 2.docx
6. Чек-лист.txt";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}