import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\d\\.\\s]+";
final String string = "3.1. Задание 1.jpg\n"
+ "3.2 Задание 1. Расчет ИМТ.docx\n"
+ "4. Задание 2.docx\n"
+ "6. Чек-лист.txt";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}