// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[\d\.\s]+").unwrap();
let string = "3.1. Задание 1.jpg
3.2 Задание 1. Расчет ИМТ.docx
4. За дание 2.docx
6. Чек-лист.txt";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}