#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(?!.*\.(?:test|spec|es[56])\.(?:(?:bundle\.)?js$)).*\.(?:bundle\.)?js$"
Local $sString = "bunle.spec.js" & @CRLF & _
"my.main.js" & @CRLF & _
"test.es6.js" & @CRLF & _
"te.es5.js" & @CRLF & _
"file.test.js" & @CRLF & _
"abc.js" & @CRLF & _
"ee.ff.abc.js" & @CRLF & _
"eeee.ffff.abc.js"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")