#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?<!\[)|(?!.{4}\]))(.)(?!\1)(.)\2\1"
Local $sString = "Any 4 char sequence which has a pair of two different characters followed by the reverse of that pair e.g xaax or raar. The string is not considered valid if the pattern above exist in square brackets." & @CRLF & _
"" & @CRLF & _
"[xaax" & @CRLF & _
"xaax]" & @CRLF & _
"[xaax]" & @CRLF & _
"" & @CRLF & _
"[raar" & @CRLF & _
"raar]" & @CRLF & _
"[raar]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")