import Foundation
let pattern = #"(?:(?<!\[)|(?!.{4}\]))(.)(?!\1)(.)\2\1"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Any 4 char sequence which has a pair of two different characters followed by the reverse of that pair e.g xaax or raar. The string is not considered valid if the pattern above exist in square brackets.
[xaax
xaax]
[xaax]
[raar
raar]
[raar]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)