use strict;
my $str = '<div>
<img class="bumbum"><img src="data:image/svg+xml,%3Csvg xmlns="http://www.w3.org/2000/svg" width="960" height="640"%3E%3C/svg%3E" />
</div>';
my $regex = qr%<img [^>]*?src=["\']data:image/svg\+xml[^>]+>%p;
my $subst = '';
my $result = $str =~ s%$regex%$subst%rg;
print "The result of the substitution is' $result\n";