$re = '%<img [^>]*?src=["\']data:image/svg\+xml[^>]+>%';
$str = '<div>
<img class="bumbum"><img src="data:image/svg+xml,%3Csvg xmlns="http://www.w3.org/2000/svg" width="960" height="640"%3E%3C/svg%3E" />
</div>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;