re = /<img [^>]*?src=["\']data:image\/svg\+xml[^>]+>/
str = '<div>
<img class="bumbum"><img src="data:image/svg+xml,%3Csvg xmlns="http://www.w3.org/2000/svg" width="960" height="640"%3E%3C/svg%3E" />
</div>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result