# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"[^"]*(for|while)\s[^"]*"//gm;t' <<< "PERFORM xxkkcsort.f_write_log(\"INFO\", \"xxkkcsort.f_load_tables__outof_order_system\", \"> Table for loading: \"||cc.source_table_name , false, null::text, 0);"