# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"[^\"]*(for|while)\s[^\"]*\""
test_str = "PERFORM xxkkcsort.f_write_log(\"INFO\", \"xxkkcsort.f_load_tables__outof_order_system\", \"> Table for loading: \"||cc.source_table_name , false, null::text, 0);"
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.