$re = '/^((?!notlike).)*$/m';
$str = 'notlike
notlik
notlikeqwe
not
not like
except';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);