#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\D+$"
Local $sString = ""a"" & @CRLF & _
"abc dsa" & @CRLF & _
"fsdfsd" & @CRLF & _
"qěč+ěčřčýřžýř" & @CRLF & _
"10" & @CRLF & _
"a b- g+ * asfd" & @CRLF & _
"" & @CRLF & _
"100" & @CRLF & _
"abc 10 dsa" & @CRLF & _
"15" & @CRLF & _
"asdfas" & @CRLF & _
"2a" & @CRLF & _
"-8" & @CRLF & _
"a5" & @CRLF & _
"" & @CRLF & _
" something ... and so one"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")