using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\D+$";
string input = @"""a""
abc dsa
fsdfsd
qěč+ěčřčýřžýř
10
a b- g+ * asfd
100
abc 10 dsa
15
asdfas
2a
-8
a5
something ... and so one";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}