import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\D+$";
final String string = "\"a\"\n"
+ "abc dsa\n"
+ "fsdfsd\n"
+ "qěč+ěčřčýřžýř\n"
+ "10\n"
+ "a b- g+ * asfd\n\n"
+ "100\n"
+ "abc 10 dsa\n"
+ "15\n"
+ "asdfas\n"
+ "2a\n"
+ "-8\n"
+ "a5\n\n"
+ " something ... and so one";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}