re = /^\D+$/m
str = '"a"
abc dsa
fsdfsd
qěč+ěčřčýřžýř
10
a b- g+ * asfd
100
abc 10 dsa
15
asdfas
2a
-8
a5
something ... and so one'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end