$re = '/^[2-9]|[1-9]\d+$/m';
$str = '2
3
10
11
5000
100001
1
-1
-8
0
a
blbl
100100
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);