# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\.0*|(?<=(\..*))0*)$//gm;t' <<< "0
0.000
10
100
0.100
0.010
1.101
1.100
1.100010
100.11
100.10"