package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)- (.+)\n?`)
var str = `- John
- Emma
- Rick
- Eva`
var substitution = "\g<1> "
fmt.Println(re.ReplaceAllString(str, substitution))
}