$re = '/^.*[^:]$/m';
$str = 'item: something
item: another
item: things:
item: yetanother';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);