re = /^.*[^:]$/m
str = 'item: something
item: another
item: things:
item: yetanother'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end