// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?im)((?:[01]\d|2[0-3]):(?:[0-5]\d):(?:[0-5]\d)) \| (Player) \"(.+)\" (.+) \(id=(.+)= (.+)=<(.+)>(.+)\"(.+)\" \(id=(.+)=(.+)\=<(.+)\>(.+)with (.+) from (.+) meters"#).unwrap();
let string = "18:43:44 | Player \"Holomo33\" (DEAD) (id=2vL1MZXKHD4qwgO6NSjoThiISfINy5SmNmuhAkbwYHM= pos=<4715.3, 10763.7, 346.8>) killed by Player \"X-CYPHER-3\" (id=aVfM8ohBvcljkZtt5CB77JOY7SNoBAh-sYK0ejvNPJc= pos=<4789.6, 10828.5, 335.4>) with LAR from 99.2274 meters
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}