import Foundation
let pattern = #"((?:[01]\d|2[0-3]):(?:[0-5]\d):(?:[0-5]\d)) \| (Player) \"(.+)\" (.+) \(id=(.+)= (.+)=<(.+)>(.+)\"(.+)\" \(id=(.+)=(.+)\=<(.+)\>(.+)with (.+) from (.+) meters"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
18:43:44 | Player "Holomo33" (DEAD) (id=2vL1MZXKHD4qwgO6NSjoThiISfINy5SmNmuhAkbwYHM= pos=<4715.3, 10763.7, 346.8>) killed by Player "X-CYPHER-3" (id=aVfM8ohBvcljkZtt5CB77JOY7SNoBAh-sYK0ejvNPJc= pos=<4789.6, 10828.5, 335.4>) with LAR from 99.2274 meters
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)