package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(Hornet ?|Valiant ?)?+(.+)`)
var str = `Mazda RX4
Mazda RX4 Wag
Datsun 710
Hornet 4 Drive
Hornet Sportabout
Valiant`
var substitution = "$1*$2*"
fmt.Println(re.ReplaceAllString(str, substitution))
}