# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[^:\r\n]*:[^:\r\n]*:"
test_str = ("_pranay_:pranay:104.144.219.145:3128\n"
"_ridhoo:rihdonk:104.144.224.242:3128\n"
"_shintna_10:shinhana:104.144.235.149:3128\n"
"_waled_jr_:ismail:104.144.241.222:3128")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.