$re = '/((?<!\+)[a-zA-Z]+)|([a-zA-Z]+(?!\+))/';
$str = '
1q+1q+1
1+q+1+q+1
q+a+123
123+a+q
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);