const regex = /(?:<a.*?>\s*[<img src="]*)(.+?)(?="?>?\s*(?:<\/a>|$))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:<a.*?>\\s*[<img src="]*)(.+?)(?="?>?\\s*(?:<\\\/a>|$))', 'g')
const str = `<tr>
<td class=""> <a href="#">Processo 1</a> </td>
<td> <a> <img src="LINK DA IMAGEM"> </a> </td>
<td> <a> <img src="LINK DA IMAGEM">
</a>
</td>
<td> <a> <img src="LINK DA IMAGEM"> </a> </td>
</tr>
<tr>
<td class=""> <a href="#">Processo 2</a> </td>
<td>
<a>
<img src="LINK DA IMAGEM"> </a> </td>
<td> <a> <img src="LINK DA IMAGEM"> </a> </td>
<td> <a> <img src="LINK DA IMAGEM"> </a> </td>
</tr>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}