package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)file (?P<path>.*?)( |\/.*?)? (?P<views>\d+).+`)
var str = `file Science/Chemistry/Quantum 444 1
file Marvel/CaptainAmerica 342 0
file Marvel/Avengers/EndGame 342 0
file Math 333 0
file Biology 224 1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}