// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)file (?P<path>.*?)( |\/.*?)? (?P<views>\d+).+").unwrap();
let string = "file Science/Chemistry/Quantum 444 1
file Marvel/CaptainAmerica 342 0
file Marvel/Avengers/EndGame 342 0
file Math 333 0
file Biology 224 1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}