#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*\w{8}-\w{4}-\w{4}-\w{4}-\w{12}\s*:\s*com.netflix.hystrix.exception.HystrixRuntimeException:\s*(?<error>.*?)\s*(\.|$)"
Local $sString = "2021-02-22 00:58:30,255 ERROR [com.xxx.yyy.interfaces.exceptions.web.ServerErrorController] (ajp-/100.10.100.100:8000-10) Unexpected failure: GET /yyy/api/zzz/aaa 500 - User: 1XX1XX1X-1X11-1111-1X11-111X11111111: com.netflix.hystrix.exception.HystrixRuntimeException: Error message."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")