import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*\\w{8}-\\w{4}-\\w{4}-\\w{4}-\\w{12}\\s*:\\s*com.netflix.hystrix.exception.HystrixRuntimeException:\\s*(?<error>.*?)\\s*(\\.|$)";
final String string = "2021-02-22 00:58:30,255 ERROR [com.xxx.yyy.interfaces.exceptions.web.ServerErrorController] (ajp-/100.10.100.100:8000-10) Unexpected failure: GET /yyy/api/zzz/aaa 500 - User: 1XX1XX1X-1X11-1111-1X11-111X11111111: com.netflix.hystrix.exception.HystrixRuntimeException: Error message.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}