package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)apidocs\/static\/[^\/]+[.](?:png|jpg|jpeg|gif|pdf)`)
var str = `./apidocs/static/mypicture.jpg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}