#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?<!")(?:"")*"[^"]*(?:""[^"]*)*"|\w+!)(*SKIP)(*F)|\b[A-Z]+\K\d+\b"
Local $sString = "SI(F5="";"";"Z_PACK_TYPE")" & @CRLF & _
"MARKET!A5" & @CRLF & _
"MARKET!MQ5" & @CRLF & _
"MARKET!AB5" & @CRLF & _
"MARKET!TX5" & @CRLF & _
"MARKET!SX5" & @CRLF & _
"MATMAS05!CZ5="3200";MARKET!DA5" & @CRLF & _
"SI(MATMAS05!CZ5="3200";MATMAS05!CZ5="3200";MARKET!DA5;"")" & @CRLF & _
"SI(L5="";"";"STRING")" & @CRLF & _
"SI(MATMAS05!CZ5="3300";MARKET!DA5;""" & @CRLF & _
"SI(ESTVIDE(MARKET!EG5);"";SI(MATMAS05!CZ5="3200";MARKET!EG5;"")"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")