use strict;
my $str = 'SI(F5="";"";"Z_PACK_TYPE")
MARKET!A5
MARKET!MQ5
MARKET!AB5
MARKET!TX5
MARKET!SX5
MATMAS05!CZ5="3200";MARKET!DA5
SI(MATMAS05!CZ5="3200";MATMAS05!CZ5="3200";MARKET!DA5;"")
SI(L5="";"";"STRING")
SI(MATMAS05!CZ5="3300";MARKET!DA5;""
SI(ESTVIDE(MARKET!EG5);"";SI(MATMAS05!CZ5="3200";MARKET!EG5;"")';
my $regex = qr/(?:(?<!")(?:"")*"[^"]*(?:""[^"]*)*"|\w+!)(*SKIP)(*F)|\b[A-Z]+\K\d+\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}