re = /(?:(?<!")(?:"")*"[^"]*(?:""[^"]*)*"|\w+!)(*SKIP)(*F)|\b[A-Z]+\K\d+\b/m
str = 'SI(F5="";"";"Z_PACK_TYPE")
MARKET!A5
MARKET!MQ5
MARKET!AB5
MARKET!TX5
MARKET!SX5
MATMAS05!CZ5="3200";MARKET!DA5
SI(MATMAS05!CZ5="3200";MATMAS05!CZ5="3200";MARKET!DA5;"")
SI(L5="";"";"STRING")
SI(MATMAS05!CZ5="3300";MARKET!DA5;""
SI(ESTVIDE(MARKET!EG5);"";SI(MATMAS05!CZ5="3200";MARKET!EG5;"")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end