#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=Amount:).*"
Local $sString = "Insurance PoIicv Amount: $1,200,000.00" & @CRLF & _
"Insurance PoIicy Amount: J25 1 000 i00_" & @CRLF & _
"Insurance Policy Amount: ##5##Q00##0 __"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")