import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Amount:).*";
final String string = "Insurance PoIicv Amount: $1,200,000.00\n"
+ "Insurance PoIicy Amount: J25 1 000 i00_\n"
+ "Insurance Policy Amount: ##5##Q00##0 __";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}