$re = '/\d+(?:\s|(?=-))/';
$str = '123 4 56-7 maine x1s56';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);