$re = '/(?<=\.\*?) |(?<!\w) (?=[A-Z])/m';
$str = '*Word. Word.* Word word. *…*
"…" Word word. "…"
"…" word. "…"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);