re = /(?<=\.\*?) |(?<!\w) (?=[A-Z])/m
str = '*Word. Word.* Word word. *…*
"…" Word word. "…"
"…" word. "…"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end