$re = '/(http:\/\/|https:\/\/)?[a-zA-Z0-9]+(\.[a-zA-Z0-9]+)*(\.[a-zA-Z0-9]{1,10})((\/+)[^\/ ]*)*/m';
$str = 'asdf asdf.com asdf.asdf .asdf ..asdf ...asdf asdf...asdf asdf.asdf.asdf/asdf asdf.asdf/asdf http://asdf http://;asdf.asdf.asdf.asdf asdfhttp://asdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);