#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?:Mr|Mrs|Miss|Dr)\.\s*|\.\s*(\w+)"
Local $sString = "There are a lot of questions about lookbehind, But I couldn't find my answer." & @CRLF & _
"" & @CRLF & _
"My RegExp with negative lookbehind is working fine in chrome but not in IE." & @CRLF & _
"" & @CRLF & _
"I need a regular expression that match any word after a period(.) but there should not be a (Mr) before the period. for example in" & @CRLF & _
"" & @CRLF & _
"'I met Mr. Jack this evening. He is a good man', but honestly Miss. Jackson, I am for real." & @CRLF & _
"" & @CRLF & _
"I want to get He, but not Jack (since it is followed by Mr.)" & @CRLF & _
"" & @CRLF & _
"so far I have comeup with the mrs. Sullivan regExp which works fine on chrome, But it doesn't on IE. and It is to be run on IE."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")